When running sls deploy, my new functions are printed but are not deployed

I’m using serverless to deploy lambdas execution to API Gateway.

When I run serverless deploy, the deployment happens without errors and endpoints for my previous functions and my new ones are printed

  POST - https://xxxx.execute-api.xxx.amazonaws.com/stage/old-stuff
  POST - https://xxxx.execute-api.xxx.amazonaws.com/stage/new-stuff
  oldStuff: bla-stage-oldStuff
  newStuff: bla-stage-newStuff

Upon seeing this, I assumed everything was fine, except that the endpoint is not visible in API Gateway. I tried running sls dpeloy list functions to check if it was visible from there, but got

Function not found: arn:aws:lambdas:xxx:xxx:function:bla-stage-newStuff

I’m assuming there’s something wrong in my yml files but don’t know where to start because I don’t get errors when deploying.

I tried to force deployment but there’s an issue with adding GSIs in the CloudFormation template. Removing the stack would also mean deleting the database, which is not desired