Sls deploy successful but nothing in AWS console

I’ve definitely seen some odd things on my serverless journey and pretty much all of the time have eventually discovered the user error that is the root cause of each problem. This latest one however has stumped me.

I decided to spin up another stage for my stack, I call it ‘edge’ - it’s an instance to try out new things and not break my dev and prod environments. Serverless.yml is here (yes breaking it up is on my todo list…)

The sls deploy -s edge command worked fine, and when I go to the service endpoint the couple of unauthenticated lambdas work as expected.

However when I run my functional test over all the lambdas, I get an error that the Cognito resources don’t exist. So I took a look in the AWS console and there is nothing there:

No cloudformation
No lambdas
No api gateway
No dydnamodb
No s3 buckets

Weird. I also checked my other AWS account thinking that somehow I’d managed to use the wrong profile. Nothing there either.

Any ideas or suggested leads to follow are welcome.

I gave this a bit of thought for 24 hrs, and spoke to a few people. Best idea we came up with was don’t use ‘edge’ as a stage value.

I just tried it with sls deploy -s alpha and it works fine.


1 Like