Sls deploy function not working - SOLVED

It was just a dumb configuration problem.
No problem with serverless.

=================================================

Hi everybody. For several days I have an error when trying to update a lambda function, and no idea why
maybe someone had the same problem
I have a gitlab runner to deploy when new commit
my gitlab-ci have this:

/usr/bin/serverless deploy function --verbose --function MyFunctionName --stage prod

The error message is:
> The function “MyFunctionName” you want to

update is not yet deployed. Please run "serverless deploy"
to deploy your service. After that you can redeploy
your services functions with the "serverless deploy
function" command.

I did deployed the function, I think the error message is a wrong message
any idea ?

If I’m trying to deploy a function that does not really exists I have the following message :

Function "MyNotExistingFunctionName"
doesn’t exist in this Service

So, I really think my initial error messaged is wrong. I have no idea why it says that my function is not deployed.
The command is launched by a gitlab runner. If I connect to the host and try to launch the same commande, I have no problem, it works.

Any idea someone ?

Thanks.

How is this solved!?