API Gateway URL (endpoint id) Changed after "sls deploy" and endpoint is not appearing in API Gateway

I recently added changes to my python lambda function and tried to redeploy to production using

sls deploy --stage prod

The endpoint appears and the deployment was successful. However, I noticed that the endpoint id changed.

example:
from : https://111222333444.execute-api.us-east-1.amazonaws.com/prod/forecast
to: https://333555777888.execute-api.us-east-1.amazonaws.com/prod/forecast

This is weird since I’ve already done multiple deployments and it never changed the endpoint id before. Another problem is I can’t use the new one created since it does not appear in API Gateway, CloudFormation and even in S3. However, in my serverless cli it was deployed under the same:
• service
• stage
• region
• stack
• resources

The only change I’ve done besides changing that one line of code was I deleted a cron event associated with this endpoint but I strongly feel it shouldn’t have affected this.

Any lead would surely be appreciated. Thank you so much!