Invoke Local Works but Deployed version times out and has empty logs

Hello, I can’t for the life of me find anything helpful online about this. We had four functions we were testing the framework with that worked perfectly. Then we build out the features we needed to connect to our database along with some other things.

We tested all our new functions in this format:
serverless invoke local --function getObjects

It worked perfectly and remarkable fast, even locally.

Once we deployed it, we didn’t get any deployment errors, we tried to test the functions in aws through the endpoints and then when that didn’t work we went and tried to test them within the AWS console.

We got 504 errors from the endpoints then when we tested them in the console log they failed from timing out no matter how long we set it for. In the logs it showed the starting and stopping of the events but was completely empty. None of our console.log functions were showing up.

I couldn’t find much online with people struggling with similar issues but I tried to make sure out IAM permissions were set but it didn’t seem to change anything.

- Effect: Allow
   - "cloudwatch:*"

Please any advice would be greatly appreciated, I can’t tell if this is a bug or not which is why I wanted to post it here before putting anything on the gitHub.