Failed to deploy Azure Python template

Has anyone tried Azure python template? I always get the following error every time I tried to do “sls deploy”:

Serverless: Parsing Azure Functions Bindings.json…
Serverless: Building binding for function: hello event: httpTrigger
Serverless: Parsing Azure Functions Bindings.json…
Serverless: Building binding for function: goodbye event: httpTrigger
Serverless: Packaging service…
Serverless: Excluding development dependencies…
Serverless: Logging into Azure
Serverless: Using subscription ID: 11a4a8e6-b562-49d9-a6bf-b52dca5fdea7
Serverless: Creating resource group: sls-weur-dev-myfunctionapp-rg

Error --------------------------------------------------

Error: Entry not found in cache.
at Logger.createError (/space/workspace/DHS/myFunctionApp/node_modules/adal-node/lib/log.js:216:13)
at TokenRequest. (/space/workspace/DHS/myFunctionApp/node_modules/adal-node/lib/token-request.js:526:40)
at /space/workspace/DHS/myFunctionApp/node_modules/adal-node/lib/token-request.js:148:20
at /space/workspace/DHS/myFunctionApp/node_modules/adal-node/lib/cache-driver.js:366:7
at /space/workspace/DHS/myFunctionApp/node_modules/adal-node/lib/cache-driver.js:276:7
at Request._callback (/space/workspace/DHS/myFunctionApp/node_modules/adal-node/lib/util.js:130:7)
at Request.self.callback (/space/workspace/DHS/myFunctionApp/node_modules/request/request.js:185:22)
at Request.emit (events.js:182:13)
at Request.EventEmitter.emit (domain.js:442:20)
at Request. (/space/workspace/DHS/myFunctionApp/node_modules/request/request.js:1161:10)
at Request.emit (events.js:182:13)
at Request.EventEmitter.emit (domain.js:442:20)
at IncomingMessage. (/space/workspace/DHS/myFunctionApp/node_modules/request/request.js:1083:12)
at Object.onceWrapper (events.js:273:13)
at IncomingMessage.emit (events.js:187:15)
at IncomingMessage.EventEmitter.emit (domain.js:442:20)
at endReadableNT (_stream_readable.js:1092:12)
at process._tickCallback (internal/process/next_tick.js:63:19)

 For debugging logs, run again after setting the "SLS_DEBUG=*" environment variable.

Your Environment Information ---------------------------
Operating System: linux
Node Version: 10.11.0
Framework Version: 1.61.3
Plugin Version: 3.3.0
SDK Version: 2.3.0
Components Core Version: 1.1.2
Components CLI Version: 1.4.0

I saw your earlier post. I also got the same issue.

Last time when I used serverless Azure templates, I managed to deploy it to Azure functions, but it was not running (Azure function not running error). Today, when I updated to the latest serverless release, I got this issue instead…

Because you should change function.js out’s name as $return.
As I knew, the plugin serverless-azure-functions do not check the language (python or nodejs). It only uses
“res” as the name of output, but according to the documentation of function app. We should use $return.

I don’t know how to change it, when we deploy, the only way is clone the plugin, and go to file: src/shared/bindings.ts

Search: binding[] = “res”; And replace res to $return, and then compile it again. Import it as local plugin.