Serverless redeployment issue with Azure

Hello everyone,

I am trying to deploy a serverless stack using Azure and Azure DevOps.

I am facing a problem with the redeployment of possible changes to the stack.

I have tried both manual deployment and also from a CICD pipeline but after the first deployment, each time i try to redeploy any changes to serverless.yml or codebase i get the following error:

TypeError: Cannot convert undefined or null to object
at Function.keys ()
at paramsNormalizer (/home/vsts/work/1/s/node_modules/serverless-azure-functions/lib/services/armService.js:258:31)
at ArmService.areDeploymentsEqual (/home/vsts/work/1/s/node_modules/serverless-azure-functions/lib/services/armService.js:275:80)
at ArmService. (/home/vsts/work/1/s/node_modules/serverless-azure-functions/lib/services/armService.js:192:34)
at step (/home/vsts/work/1/s/node_modules/serverless-azure-functions/lib/services/armService.js:56:23)
at Object.next (/home/vsts/work/1/s/node_modules/serverless-azure-functions/lib/services/armService.js:37:53)
at fulfilled (/home/vsts/work/1/s/node_modules/serverless-azure-functions/lib/services/armService.js:28:58)
at process._tickCallback (internal/process/next_tick.js:68:7)

For debugging logs, run again after setting the “SLS_DEBUG=*” environment variable.

Get Support --------------------------------------------
Docs: docs.serverless.com
Bugs: github.com/serverless/serverless/issues
Issues: forum.serverless.com

Your Environment Information ---------------------------
Operating System: linux
Node Version: 10.19.0
Framework Version: 1.63.0
Plugin Version: 3.3.0
SDK Version: 2.3.0
Components Core Version: 1.1.2
Components CLI Version: 1.4.0

Also to add that I have tried with :

  • Passing no Resource group ( let serverless create the respective one)
  • Initializing it in the serverless.yml file ( resourceGroup: myresourcegroupname)
  • Passing it with the serverless deploy -g myresourcegroupname

Thanks,
Konstantinos

Hey Konstantinos, i’m having the exact same situation you detailed above. Were you able to make any progress on a solution?

I have the same issue on:
OS: linux ubuntu 18
Node version: 12.16.0
Framework version: 1.63.0
Plugin version: 3.3.0
SDK Version: 2.3.0
Components Core version: 1.1.2
Components CLI Version: 1.4.0

Regards, Pawel

Hello,

I had a similar problem and after debugging the error identified that it’s because the previous deployment templates used don’t have any parameters. The plugin isn’t handling this, I’ve raised this on github.

Whilst the fix is being added the solution would be to go to the Azure portal and delete the previous deployments (or if you want to be more specific, go through each of them and delete any deployments which have ZERO parameters).

Cheers
Bruce