Azure Serverless.yml Java Example?

I am in the process of duplicating my AWS implementation to Azure. I have setup an example function as described here: ( . I run the following and everything works perfectly:

mvn azure-functions:deploy

I then looked at the docs on Serverless site to create a simple serverless.yml file. I wrote this:

service: sls-service

  name: azure
  location: West US

  - serverless-azure-functions

      individually: true
      artifact: ./target/
       - http: true
           authLevel : anonymous

The deployment can’t get by the function provisioning. It just hangs. It also provisions storage in a different region then the function (unlike the mvn deploy is all in the same region)

The error in the resource group is:

Cannot modify this web hosting plan because another operation is in progress. Details: Id: 31787008-0421-4611-b632-f159e0e50310, OperationName: Create, CreatedTime: 4/30/2018 4:02:11 PM, RequestId: 42805be6-a842-4d36-93b6-7e84770c1fc9, EntityType: 9

Before I ran this I had no processes running on Azure

Has anyone done a successful Java based deployment to azure and would share their serverless.yml that works?

I got this to work by changing the location to Central US. Not sure why it fixed the problem?