Severless Error: output greater than 60?

I upgraded from 1.2.0 to 1.3.0. Ran deploy and received a serverless error saying I had 74 outputs which is greater than the 60 allowed. What does this mean?

I downgraded to 1.2.0 and all works fine.

I ran into this problem again. had to downgrade to version 1.2.0. Anyone have an answer to the question?

Here is what the serverless cli responded with when I did sls deploy:

Serverless: Creating Stack…
Serverless: Checking Stack create progress…
CloudFormation - CREATE_IN_PROGRESS - AWS::CloudFormation::Stack - user-service
CloudFormation - CREATE_IN_PROGRESS - AWS::S3::Bucket - ServerlessDeploymentBucket
CloudFormation - CREATE_IN_PROGRESS - AWS::S3::Bucket - ServerlessDeploymentBucket
CloudFormation - CREATE_COMPLETE - AWS::S3::Bucket - ServerlessDeploymentBucket
CloudFormation - CREATE_COMPLETE - AWS::CloudFormation::Stack - user-service
Serverless: Stack create finished…
Serverless: Packaging service…
Serverless: Uploading CloudFormation file to S3…
Serverless: Uploading service .zip file to S3 (6.8 MB)…
Serverless: Updating Stack…

Serverless Error ---------------------------------------

 Template format error: Outputs count 72 is greater than
 max allowed 60

Get Support --------------------------------------------

Your Environment Information -----------------------------
OS: linux
Node Version: 4.6.1
Serverless Version: 1.3.0

I also have this problem.

A brief google yields this result:

It looks like the cloudformation template serverless generates hits some sort of limit when the deployed environment gets big?

Further info - serverless generates the “Outputs” section of the cf-templae to allow other cf-templates to reference these resources. I’m looking to see if serverless has a way of limiting or disabling this, which is especially useful if you don’t plan on exposing anything to other templates (and want to build successfully).

Okay looks like there isn’t. From looking at the code it seems like serverless will add two entries into the Outputs section of the cf-template as part of the compileFunction() and there’s no settings check.

So in other words, if you have more than 30 lambdas you will hit this error.

I’m going to see what I can do about this

Our current solution is to replace the offending file with a copy, but with the offending lines commented out