Output limit 60 problem - despite having versionFunctions:false

Hi - We’re continuing to have problems with the “output 60” limit.
Here’s what’s already been done:

  • In the serverless.yml there is already a “versionFunctions: false” in the provider section. When I run “sls info --verbose” it only shows two outputs.
  • In CloudFormation console though, under Outputs it shows an entry for each of the http paths.
  • We have combined several lambdas into one that does routing. Yet still each of the http paths shows up as an output.
  • We are using serverless-plugin-split-stacks to get around the total 200 resource limit. That is effectively splitting up the total resources into four different stacks. But all the “outputs” live in just one of them.

What are we doing wrong?

Here’s an update. The issue appears to be that one Output is being created per path, for an ApiGateway resource.

So “GET /foo/{id}” and “PUT /foo/{id}” and “DELETE /foo/{id}” together consume one Output, namely ApiGatewayResourceFooIdVar. When I add “GET /foo” that consumes another, and “GET /bar” another.

These ApiGateway Output objects are only being created when the serverless-plugin-split-stacks plugin is used.

So this is a scaling limit related to that plugin - the total number of unique paths in serverless.yml can’t exceed 60.

Update^2 - solved. Just need to make sure that all the different ApiGatewayResource paths are not put into the same stack by the split-stacks plugin.