Serverless_sdk.get_user_handler: module has no attribute

Howdy,

Been awhile since I posted something, but I’m trying to use the new monitoring services on a project and am seeing an error with just one of my 12 functions that seems a little weird.

In the generated s_.py file the framework creates to provide the monitoring, there’s a call on line 14:

user_handler = serverless_sdk.get_user_handler('packages/csv.csv')

The ‘packages/csv.csv’ refers to the path where the intended function can be found and for this specific function, when invoked I get the following output to CloudWatch:

module 'csv' has no attribute 'csv': AttributeError 

Has anybody seen this? I tried redeploying and there’s nothing obviously different about how this function is structured or referenced compared to my others. Other functions in the same folder work just fine, but I’m missing some detail here that’s not revealing itself to me.

1 Like

Hmm, changed the function name, file, method name to something longer and it worked. Very weird.