"no zip file found" error with the quick start guide


I’m following the quick start guide to create my first serverless service and I’m not sure why it’s not working.

Guide: https://serverless.com/framework/docs/providers/aws/guide/quick-start/

OS: Win32
NodeJS: 10.15.1
Serverless: 1.14.1

What I did:

  1. Globally installed serverless and followed the instructions for setting my provider credentials.
  2. Ran “serverless create --template aws-nodejs --path …/testcommand”, which created a folder called ‘testcommand’ with the template code in it.
  3. Opened the folder in VS Code and ran “serverless deploy -v” in a terminal.

I then got the following debug log:

Serverless: Packaging service…
Serverless: Excluding development dependencies…

Serverless Error ---------------------------------------

No {path to my repo directory removed}\testcommand\.serverless\testcommand.zip file found in the package path you provided.


I tried “serverless deploy” but got the same result.
Is there a separate command I need to run to generate the file or something else I need to set up not mentioned in the guide?

Reason found. I defined the path as “…/testcommand” so that was also the value of ‘service’ in serverless.yml, which caused it to fail.