Local OpenWhisk cert error?

openwhisk

#1

Trying out the examples for the plug in and they work great against Bluemix, but I’m getting a certificate error when running against a local OpenWhisk install:

Failed to deploy function (my_service2-dev-hello) due
to error: Error encountered calling OpenWhisk: Error:
self signed certificate

and I can duplicate it with the wsk CLI just trying a hello:

error: Unable to invoke action 'utils/echo': Post https://192.168.33.13/api/v1/namespaces/whisk.system/actions/utils/echo?blocking=true&result=true: x509: cannot validate certificate for 192.168.33.13 because it doesn't contain any IP SANs

I’m not finding anything on certs on the OpenWhisk project page anywhere, so I thought I’d try here. Has anybody else run into this?


#2

UPDATE

I get the same self signed cert error when I vagrant ssh into my OpenWhisk box and install the serverless framework there, even after setting the environment variables as instructed. Unlike when I tried it before, the wsk command line works just fine here, though.

Anybody else run into this?


#3

Hi I have got this error too. With the wsk the -i option solves it, but in this case not. I have seen a possibility (rest api) to send over this ignore option in the contractor for the deploy.

Did you solved the problem?


#4

Nope, still seeing it. Misery loves company though 8)


#5

The issue is accepted and will be part of the the release / update. See below the Github issue record with comment history.

https://github.com/serverless/serverless-openwhisk/issues/36


#6

This has now been resolved with the 0.5 release of the plugin, please upgrade and try again.

Use the following configuration to support this.

provider:
    name: openwhisk
    ignore_certs: true
```

#7

I finally got a chance to validate this and it’s working great now, thanks so much.

I hope we get a chance to meet in Vegas, I get there Tuesday morning and hope to escape the show floor for a few OpenWhisk sessions.