Deploy project without functions fails since 1.12.0

I have a “core” stack that defines resources that are shared by multiple stacks(client api, vendor api, internal website, etc). This core stack doesn’t include any Lambda functions.
Prior to release 1.12.0 it deployed without issue(to aws).

Since 1.12.0, it fails with the following message:

Serverless Error ---------------------------------------

 No file found in the package path you

If I add a function, it deploys fine, but if I then remove that function, it fails again.
Tried with release 1.12.0 & 1.12.1 and receive the above error.
Reverted back to 1.11.0 and all is fine.

Is this a bug, or am I attempting to use the serverless framework in an unsupported fashion?

Thanks in advance.

1 Like

Services without functions is definitely a valid use-case - I remember when @johncmckim implemented it.

You should log an issue.

Thanks for the confirmation @rowanu.
Looks like somebody beat me to creating the issue. But I’ll keep my eye on it.

Hi @bfieber @johncmckim ,

Im getting this problem now. Do you know if it was solved?

Not sure it was ever "solved"
But to make it happy, I just have a “dummy” function in my core that nobody/nothing calls.

It was a bug.

Should be fixed in current version.

1 Like