Application not found - 0T43W23ZG344

Hello! I am trying to deploy a Lambda function. The creator of the service made a user account for me with the right permissions for AWS and I logged in serverless. I simply cloned the repo with the code and ran serverless config credentials.

When I run sls deploy, I get the following:

sls deploy
Serverless: Packaging service...
Serverless: Excluding development dependencies...
Serverless: Uploading CloudFormation file to S3...
Serverless: Uploading artifacts...
Serverless: Uploading service .zip file to S3 (10.35 KB)...
Serverless: Validating template...

  Error --------------------------------------------------

  Error: {"errorMessage":"Application not found. - Please contact support and provide this identifier to reference this issue - 0T43W23ZG344"}

     For debugging logs, run again after setting the "SLS_DEBUG=*" environment variable.

  Get Support --------------------------------------------

  Your Environment Information -----------------------------
     OS:                     win32
     Node Version:           8.11.3
     Serverless Version:     1.32.0

What could be causing the problem?

It gave me this error because when I logged in my serverless account and opened the admin panel, the application I tried to deploy from (app in serverless.yml) indeed didn’t exist. Instead, I used another application from my account that did exist and it worked. More info in my other thread.

1 Like

Thanks for posting. I had the same problem — I was porting a project from Node to Python and hadn’t set up a new serverless app. Your message bridged the cryptic gap between the error and my simple mistake.

1 Like

Cara, eu acho que você só pulou a etapa incial: