Permission denied when Uploading artifacts

OSX - 10.12.6
Node - 6.11.5
Docker - 17.12.0-ce
Serverless - 1.25.0

I’ve been experiencing this strange issue lately. I can deploy my (Google) cloud functions just fine sometimes but then after a code change and an attempt to redeploy I receive the following

Serverless: Uploading artifacts...
      throw er; // Unhandled stream error in pipe.

Error: EACCES: permission denied, open '/root/project/src/.serverless/'
    at Error (native)

I have a Docker container with a mapped volume to the project directory. I do not believe it has anything to do with Docker though, as I have attempted to deploy from my local system (OSX) and within the Docker container. I receive the same error. I’ll delete the .serverless dir, run sls remove a few times and suddenly it’ll work then the immediate next deploy it throws the same error. It’s as if the account attempting to open and upload the .zip that was packaged on deploy suddenly doesn’t have permissions to open it. Anyone ever experience this?