Dry runs / noDeploy cli option disappeared in 2.36.0

Hello, I’ve got a question as I was about to file a bug report - but am wondering if it is a bug, or if there’s an intention behind the change:

So this pull from 9 April

Includes the line

Remove handling of internal noDeploy option

And the release information for 2.36.0 includes the line:

  • Remove support for internal noDeploy option (#9281) (688d09b) (Mariusz Nowak)

And ever since then, the --noDeploy cli flag does not work. I can’t do a dry-run deployment.

This contradicts the documentation, but the documentation could be out of date. I would be happy to open a PR to update the docs, but I don’t know what the intention was behind removing noDeploy and if there’s a way of running a dry-run deploy from the command line?

I have now also asked this question in Dry runs / noDeploy cli option disappeared in 2.36.0 · Discussion #9389 · serverless/serverless · GitHub – not sure which platform is the better options.

As covered in the linked discussion on Github, running sls package does the majority of what --noDeploy did and certainly covers my use case