CORS Problem, or maybe I'm just being a chump?

Hey guys,

I’m on the latest version of serverless and I’m trying to setup CORS for my endpoints. As an experiment I tried it on my simple ping endpoint which is part of my Utilities Serverless Service, and with my first sls deploy worked perfectly. However any subsequent sls deploy’s against the serverless service just hang at “Checking Stack update progress…”. Is this a known issue or am I missing the boat here?

The ymal for my ping endpoint is as follows

    name: ${opt:stage, self:custom.defaultStage}-ping
    handler: dist/
        - 'dist/!(ping-handler.js)'
        - 'dist/node_modules/mysql/**'
        - 'dist/node_modules/get-json/**'
      - http:
          path: ping
          method: get
          integration: lambda
          cors: true

After a bit of testing it seems that CloudFormation completes and its serverless that is still sat there stuck in “Checking Stack update progress…”. Interestingly if I alter the ymal the sls deploy seems to go through again.