BillingMode - UnexpectedParameter


#1

Hello everyone.

Need help with this error -

{
“errorMessage”: “RequestId: 18120028-124f-11e9-9e46-b3db6ae39b34 Process exited before completing request”
}

Also, I have the following in the logs

2019-01-07T07:37:32.797Z 18120028-124f-11e9-9e46-b3db6ae39b34 UnexpectedParameter: Unexpected key ‘BillingMode’ found in params
at ParamValidator.fail (/var/runtime/node_modules/aws-sdk/lib/param_validator.js:50:37)
at ParamValidator.validateStructure (/var/runtime/node_modules/aws-sdk/lib/param_validator.js:77:14)
at ParamValidator.validateMember (/var/runtime/node_modules/aws-sdk/lib/param_validator.js:88:21)
at ParamValidator.validate (/var/runtime/node_modules/aws-sdk/lib/param_validator.js:34:10)
at Request.VALIDATE_PARAMETERS (/var/runtime/node_modules/aws-sdk/lib/event_listeners.js:125:42)
at Request.callListeners (/var/runtime/node_modules/aws-sdk/lib/sequential_executor.js:105:20)
at callNextListener (/var/runtime/node_modules/aws-sdk/lib/sequential_executor.js:95:12)
at /var/runtime/node_modules/aws-sdk/lib/event_listeners.js:85:9
at finish (/var/runtime/node_modules/aws-sdk/lib/config.js:320:7)
at /var/runtime/node_modules/aws-sdk/lib/config.js:338:9

Here is my package.json

{
  "name": "xxxxxxx",
  "version": "1.0.0",
  "description": "",
  "main": "index.js",
  "scripts": {
    "test": "echo \"Error: no test specified\" && exit 1"
  },
  "author": "",
  "license": "ISC",
  "dependencies": {
    "aws-sdk": "^2.382.0",
    "serverless-dynamodb-local": "^0.2.35",
    "uuid": "^3.3.2"
  },
  "devDependencies": {
    "bcrypt-nodejs": "0.0.3",
    "dynamoose": "^1.3.0",
    "factory-girl": "^5.0.4",
    "faker": "^4.1.0",
    "moment": "^2.23.0",
    "serverless-aws-documentation": "^1.1.0",
    "serverless-mocha-plugin": "^1.9.1",
    "serverless-offline": "^3.31.3",
    "serverless-plugin-include-dependencies": "^3.2.1",
    "serverless-reqvalidator-plugin": "^1.0.3",
    "serverless-webpack": "^5.2.0",
    "webpack": "^4.27.1"
  }
}

#2

Am having the same error.
But yours might be related to the dynamodb local plugin that you use.


#3

if the issue is with the dynamodb local plugin, then it’s weird because the endpoints for me works fine locally, however when I deploy it and run it, then it fails. I have also moved the serverless-dynamodb-local from dependencies to devDependencies