Serverless.yml AWS parameter store JSON

 Operating System:          darwin
 Node Version:              12.18.1
 Framework Version:         2.14.0 (standalone)
 Plugin Version:            4.1.2
 SDK Version:               2.3.2
 Components Version:        3.4.2

I’m trying to use JSON stored in AWS Parameter store to set variables in my serverless.yml file.

I’m able to retrieve the JSON data, but serverless doesn’t parse it like it would do for Secret Manager strings.

Here’s an example of how I retrieve data from the parameter store

   myConfig: ${ssm:/app/${self:provider.stage}/config/myConfigJson~true}

Then when I run SLS print --stage myEnv to see what resolves, I get the following:

  myConfig: >- :{"Bar":"someValue","Foo":"someOtherValue"}

Because it’s a JSON string, I can’t access Bar or Foo directly… or can I ?

I went with the assumption that I can’t, and tried the resolver method
(note: I can’t use the newer resolver since I’m locked to v2 of the framework)

The problem I’m facing with this, is that in the documentation it shows

serverless.cli.consoleLog('You can access Serverless config at serverless.configrationInput');

But when I log out serverless.configurationInput and run sls print or sls offline it’s undefined in both cases. I need to be able to access myConfig from the custom object from the config in the resolver file… is there a way to do that?