Serverless deploy failing since 1.71.2

Upgraded to serverless 1.71.3 today and deploys started failing:

Serverless: Parsing Python requirements.txt
Serverless: Installing required Python packages for runtime python3.6...
Serverless: Linking required Python packages...
Serverless: Packaging service...
Serverless: Excluding development dependencies...
 
  Error --------------------------------------------------
 
  Error: ENOTDIR: not a directory, scandir '/home/circleci/project/_pyrsistent_version.py'
 
     For debugging logs, run again after setting the "SLS_DEBUG=*" environment variable.
 
  Get Support --------------------------------------------
     Docs:          docs.serverless.com
     Bugs:          github.com/serverless/serverless/issues
     Issues:        forum.serverless.com
 
  Your Environment Information ---------------------------
     Operating System:          linux
     Node Version:              8.11.3
     Framework Version:         1.71.3
     Plugin Version:            3.6.12
     SDK Version:               2.3.0
     Components Version:        Unavailable
 

Exited with code exit status 1

Still got the same error when I downgraded to 1.71.2, but it worked when I downgraded to 1.71.1. Is this a known issue? Be happy to report an issue in the Github repo if need be.

Thanks.