Serverless - Cannot access package artifact ".\serverless\" ...currently on 4th day trying to get this to work

Trying to get this to deploy. After a series of problem after problem I have finally wound up here and cannot seem to get around it, even with symlinks or custom plugins. When i go to deploy, I get this error message:
Cannot access package artifact at “.serverless\” (for “hello”): ENOENT: no such file or directory, access ‘C:_DEV\Amazon\\’

I can see ./.serverless/ exists. I can also confirm that there is no .build.serverless folder.

I’ve put this in my serverless.yml

artifact: C:/_DEV/Amazon/serverless-project/.build/.serverless/

Tried individually: true

Tried removing all package information from serverlss.yml

Tried building ModifyArtifactPlugin with this:
this.hooks = {
‘before:deploy:createDeploymentArtifacts’: this.modifyArtifact.bind(this),
and entered into plugins in serverless.yml

Tried --no-package
Tried to mess with the source. Tried to redefine __dirname in webpack.config.js

NOTHING. I’m just about done, ready to spike serverless and go to some other solution. Anyone got any ideas?

webpack.config.js - webpack.config.js -

serverless.yml - serverless.yml -

I had the same issue, this is how I resolved it.

in my case, I removed serverless-plugin-typescript from the serverless.yml because it was conflicting with serverless-bundle which already has support for typescript. Try this and see if it works for you.