Python-Requirements Docker Error

Hi gang,

I am following the guide written here: https://serverless.com/blog/serverless-python-packaging/ in a Windows environment. I installed Docker and granted it access to my C drive. When I try to deploy I receive the following error during the Docker Image step:

Serverless: Installing requirements of requirements.txt in .serverless...
Serverless: Docker Image: lambci/lambda:build-python3.6

 Error --------------------------------------------------

 Unable to find good bind path format

I found a commit commit which indicates this is related to a docker failure.

Any ideas?

Update

So I ran a Docker tutorial to make sure my setup worked independently of serverless, and received odd errors. Per a post (too new to post link only get 2) I resolved a time out by changing my default DNS.

So now, I have a new fun error message:

Serverless: Docker Image: lambci/lambda:build-python3.6

  Error --------------------------------------------------

  docker: invalid reference format: repository name must be lowercase.

Will update if I resolve this one.

update

Building the project failed when the project path contained a space. So building out of c:\users\jonny waffes\testproject failed but c:\testproject succeeded.

Hi

I’ve gotten this error twice. It happens error after having reset the password of my Windows user. The solution for me has been to go into “Docker > Settings > Shared Drives” click “Apply” and then input my new password! :slight_smile:

1 Like