Lambda EACCESS -13

I recently added a new script to my deployment and redeployed but now all of my lambda scripts are returning
“errorType”: “Error”,
“errorMessage”: “EACCES: permission denied, open ‘/var/task/getSources.js’”,
“code”: “EACCES”,
“errno”: -13,
“syscall”: “open”,
“path”: “/var/task/getSources.js”,
“stack”: [
“Error: EACCES: permission denied, open ‘/var/task/getSources.js’”,
" at Object.openSync (fs.js:458:3)",
" at Object.readFileSync (fs.js:360:35)",
" at Object.Module._extensions…js (internal/modules/cjs/loader.js:1157:22)",
" at Module.load (internal/modules/cjs/loader.js:986:32)",
" at Function.Module._load (internal/modules/cjs/loader.js:879:14)",
" at Module.require (internal/modules/cjs/loader.js:1026:19)",
" at require (internal/modules/cjs/helpers.js:72:18)",
" at _tryRequire (/var/runtime/UserFunction.js:75:12)",
" at _loadUserApp (/var/runtime/UserFunction.js:95:12)",
" at Object.module.exports.load (/var/runtime/UserFunction.js:140:17)"

A quick google search seems this is a permission issue. Just to ensure I chmodded my files to 644 and directories to 755, I even ran a test with everything at 777, and I still get the same issue. I dont have direct deploy access, and I deploy via Jenkins. Perhaps when Jenkins runs the deploy its writing out as something other than what I set?

It turns out our Jenkins deployment somehow changed the permissions of the directory it pulls the github repository into to package. Once that was fixed it worked.