Issue with yml file

Hello, I am a newbie, trying to make a Facebook Bot and am following the example provided.

My YML file consists of

- http:
path: webhook
method: get
integration: lambda
- http:
path: webhook
method: post
integration: lambda
as specified.

However when I run “serverless deploy” I get the following error

E:\serverless\gitaquote>serverless deploy

Y A M L Exception --------------------------------------

 end of the stream or a document separator is expected
 in "E:\serverless\gitaquote\serverless.yml" at line
 68, column 4:
      - http:

 For debugging logs, run again after setting SLS_DEBUG env var.

Get Support --------------------------------------------

 Please report this error. We think it might be a bug.

Your Environment Information -----------------------------
OS: win32
Node Version: 6.5.0
Serverless Version: 1.2.1

Can someone point what is going wrong?


1 Like

OK, I figured this out. the integration:lambda isn’t required.
Also, that it is advisable to use spaces rather than tabs

1 Like

Could you upload whole your serverless.yml?


I know it’s been a while since this was posted, but I’m facing a similar error and this post was the most similar to what I’m experiencing right now.

Can you please elaborate on how exactly you solved your problem? Also, did you receive support from Serverless staff? If yes, can you please send me the issue’s link on GitHub?