Error while running google node simple http endpoint example

I am following the example at:

I already have my keyfile correctly configured in serverless.yml ( mykeyfilename-bf8946190e20.json ) and the related service account has the owner permissions (i.e., can do everything).

After doing serverless deploy, I get the following error:

Error: Deployment failed: RESOURCE_ERROR
   {"ResourceType":"cloudfunctions.v1beta2.function","ResourceErrorCode":"500","ResourceErrorMessage":"Failed to initialize region (action ID: 282bb89f86aa51e0)"}
  at provider.request.then.catch (/home/omar/repos/bibi/backend/google-node-simple-http-endpoint/node_modules/serverless-google-cloudfunctions/shared/monitorDeployment.js:51:24)
  at process._tickCallback (internal/process/next_tick.js:68:7)
 For debugging logs, run again after setting the "SLS_DEBUG=*" environment variable.
  Get Support --------------------------------------------
  Your Environment Information ---------------------------
 Operating System:          linux
 Node Version:              10.8.0
 Framework Version:         1.63.0
 Plugin Version:            3.3.0
 SDK Version:               2.3.0
 Components Core Version:   1.1.2
 Components CLI Version:    1.4.0

EDIT: Tried hardcoding the region in serverless.yml (region: us-west1-a) but it sill breaks with the same error.

Moved on to using AWS… the first example I tried worked. Apparently there is something wrong with GCS.