Error in retrieving cloudformation template

aws

#1

Hello, I am fairly new to serverless and I am getting the following error when trying to deploy. I created the bucket and the file does exist.

Here is my serverless.yml (without the lambdas):

provider:
name: aws
runtime: python2.7
role: arn:aws:iam::ACCT_NUMBER:role/LambdaExecutionRole
profile: nitro-dev
deploymentBucket:
name: REDACTED
serverSideEncryption: AES256 # when using server-side encryption
environment:
ENV: dev1
REGION: us-west-2
BASE_URL: REDACTED
stage: dev1
region: us-west-2

When I run sls deploy:

$ sls deploy --verbose

Serverless: WarmUP: setting 5 lambdas to be warm
Serverless: WarmUP: REDACTED
Serverless: WarmUP: REDACTED
Serverless: Installing requirements of requirements.txt in .serverless…
Serverless: Packaging service…
Serverless: Excluding development dependencies…
Serverless: Excluding development dependencies…
Serverless: Injecting required Python packages to package…
Serverless: Uploading CloudFormation file to S3…
Serverless: Uploading artifacts…
Serverless: Uploading service .zip file to S3 (12.66 MB)…
Serverless: Uploading service .zip file to S3 (755 B)…
Serverless: Validating template…
Error --------------------------------------------------
The CloudFormation template is invalid: S3 error: Unable to get the object https://s3.amazonaws.com/REDACTED/serverless/dev1/1535520222094-2018-08-29T05:23:42.094Z/compiled-cloudformation-template.json

I am not sure why the cloudformation template cannot be fetched from S3 as it does exist and my IAM credentials have access to download it. Any help will be appreciated.

Thanks
Arani


#2

I run into the same issue. Did anyone work around it?


#3

Hi there, Have you got that solved? Met the same issue.