Deploying Lambda Service Failing Because Domain Missing in API Gateway?

api-gateway
aws
lambda

#1

Hi everyone,

I’ll just prefix this question with I am very new to working within AWS Serverless having previously worked with Azure. So there is a fair chance I am missing something obvious here, but here goes…

I am currently trying to deploy my lambda service to AWS, and when I run ‘sls deploy --stage dev’ I get to the point where it starts to package the service but then falls over giving the error:

Error: Could not set up basepath mapping. Try running sls create_domain first.
Error: Error: ‘dev-api.mywebsite.com’ could not be found in API Gateway.
CredentialsError: Missing credentials in config

However, when I look in API Gateway I can see that the domain it’s referring to exists. So this leads me onto the next message which states about missing credentials. I’m assuming it’s expecting a certificate to be installed on my machine? If I’m right, how can I get this from within AWS Console? If I’m wrong, does anyone know where I should be trying next.