Can't perform functions on dynamodb local since mc mojave update

dynamodb

#1

I have installed the serverless-dynamodb-local plugin and was able to locally run the dynamodb without any issues.

Recently my mac updated the OS to mojave and things seems to be broken. I am able to start and run the dynamodb with sls dynamodb start --migrate, but I am unable to perform any actions.

A simple action like below times out

client = boto3.client('dynamodb', endpoint_url='http://localhost:8000')
client.list_tables()

and throws error

botocore.exceptions.ClientError: An error occurred (503) when calling the ListTables operation (reached max retries: 9)

I had some similar problems when update to Mojave, with Android Emulators and other apps stopped worked due to permissions issue and the OS wasnt asking them. But after I killed the apps and restarted them, then the right permissions were asked and once when granted, worked perfectly fine.

I believe the issue here is also permissions related one, which the OS is not asking for. So it is hard to know what is needed? If someone can give any suggestions would be great.