# What can cause a successful deployment to fail when redeploying?

**URL:** <https://forum.serverless.com/t/what-can-cause-a-successful-deployment-to-fail-when-redeploying/13625>\
**Category:** Serverless Framework\
**Tags:** aws\
**Created:** [January 7, 2021, 5:44pm UTC](https://forum.serverless.com/t/what-can-cause-a-successful-deployment-to-fail-when-redeploying/13625 "2021-01-07T17:44:35Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![gilad-embryonics](https://yyz2.discourse-cdn.com/flex036/user_avatar/forum.serverless.com/gilad-embryonics/32/5020_2.png) [@gilad-embryonics](https://forum.serverless.com/u/gilad-embryonics)\
**Post date:** [January 7, 2021, 5:44pm UTC](https://forum.serverless.com/t/what-can-cause-a-successful-deployment-to-fail-when-redeploying/13625/1 "2021-01-07T17:44:35Z")

</div>

Two days ago it deployed successfully, now getting ‘The CloudFormation template is invalid’  
nothing changed in the config file serverless.yml

---

<div class="post-metadata">

**Author:** ![rdyar](https://yyz2.discourse-cdn.com/flex036/user_avatar/forum.serverless.com/rdyar/32/5037_2.png) [@rdyar](https://forum.serverless.com/u/rdyar)\
**Post date:** [January 10, 2021, 6:51pm UTC](https://forum.serverless.com/t/what-can-cause-a-successful-deployment-to-fail-when-redeploying/13625/2 "2021-01-10T18:51:34Z")

</div>

what part failed? was there more info?

I am getting:  
Error: The CloudFormation template is invalid: Template format error: Unresolved resource dependencies [ApiGatewayResourceAppAnyVar] in the Resources block of the template
