# Unable to deploy to Azure

**URL:** https://forum.serverless.com/t/unable-to-deploy-to-azure/9358
**Category:** Serverless Framework
**Tags:** azure
**Created:** [September 17, 2019, 6:07pm UTC](https://forum.serverless.com/t/unable-to-deploy-to-azure/9358 "2019-09-17T18:07:15Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![jhlws](https://yyz2.discourse-cdn.com/flex036/user_avatar/forum.serverless.com/jhlws/32/3623_2.png) [@jhlws](https://forum.serverless.com/u/jhlws)
#### Post date: [September 17, 2019, 6:07pm UTC](https://forum.serverless.com/t/unable-to-deploy-to-azure/9358/1 "2019-09-17T18:07:15Z")

</div>

Hi,

I’m having issues deploying to Azure, looks like an issue with authentication.

To get to the bottom of it I have tried deploying the azure-nodejs template.

Have tried both interactive and service principal login.

Key error is: Error: Authentication returned an empty list of subscriptions. Try another form of authentication. See the serverless-azure-functions README for more help.

Definitely a subscription present.

---

<div class="post-metadata">

### Author: ![csplinter](https://yyz2.discourse-cdn.com/flex036/user_avatar/forum.serverless.com/csplinter/32/3637_2.png) [@csplinter](https://forum.serverless.com/u/csplinter)
#### Post date: [September 22, 2019, 11:16pm UTC](https://forum.serverless.com/t/unable-to-deploy-to-azure/9358/2 "2019-09-22T23:16:16Z")

</div>

Hi,

I was having a similar problem and was only able to find success following the instructions below. Hope these can help.

> **[serverless/serverless-azure-functions](https://github.com/serverless/serverless-azure-functions#advanced-authentication)**
>
> Serverless Azure Functions Plugin – Add Azure Functions support to the Serverless Framework - serverless/serverless-azure-functions

---

<div class="post-metadata">

### Author: ![AronNovak](https://yyz2.discourse-cdn.com/flex036/user_avatar/forum.serverless.com/aronnovak/32/4657_2.png) [@AronNovak](https://forum.serverless.com/u/AronNovak)
#### Post date: [October 27, 2020, 9:22am UTC](https://forum.serverless.com/t/unable-to-deploy-to-azure/9358/3 "2020-10-27T09:22:22Z")

</div>

Thanks, I can confirm that the simple way does not work, but the advanced authentication using AZ CLI works, beginning with:  
az ad sp create-for-rbac --name

---

<div class="post-metadata">

### Author: ![Benwalker](https://avatars.discourse-cdn.com/v4/letter/b/848f3c/32.png) [@Benwalker](https://forum.serverless.com/u/Benwalker)
#### Post date: [June 25, 2021, 11:28am UTC](https://forum.serverless.com/t/unable-to-deploy-to-azure/9358/4 "2021-06-25T11:28:31Z")

</div>

I would suggest you to take the advantage of utilizing [azure migration consulting](https://nuvento.com/cloud-managed-services/azure-migration-services/) services where all the basic framework and services are managed appropriately. Even I had faced an issue where I get a deployment failed when I enter ‘git push azure master’, near the end. It was resolved easily.
