Sudden latency increases

Hey guys, I run a very simple CRUD API using the serverless framework. I am using Node v10 and serverless v1.57.0

My CRUD app is not complex at all, it accesses a DynamoDB table and returns results. It usually responds in about 15-20ms with no problem (2kb payload).

Once in a while, however, I will run sls deploy and suddenly I get 6+ second response times from any endpoint that was deployed. If I deploy a certain function, that function is now slow. I can’t seem to undo this - if I run rollback, the 6 second latency remains. I want to stress that there are no code changes or database changes. This seems to be a serverless problem.

Has anyone experienced anything similar?

Looks like a similar problem occurred here: After upgrade to v1.57.0, new deployments of existing services run x2000 times slower

It would appear that removing the app line from your serverless.yml file will get rid of this latency!

Hey there. As I responded on the other thread, would you be able to share your serverless.yml? If you prefer, you can create a private gist and send it to me personally if you don’t want to do it publicly.