# ServerlessError: Invalid tag key. Tag keys cannot start with 'aws:'

**URL:** <https://forum.serverless.com/t/serverlesserror-invalid-tag-key-tag-keys-cannot-start-with-aws/15149>\
**Category:** Serverless Framework\
**Created:** [May 28, 2021, 7:18am UTC](https://forum.serverless.com/t/serverlesserror-invalid-tag-key-tag-keys-cannot-start-with-aws/15149 "2021-05-28T07:18:34Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![edwar95](https://yyz2.discourse-cdn.com/flex036/user_avatar/forum.serverless.com/edwar95/32/5777_2.png) [@edwar95](https://forum.serverless.com/u/edwar95)\
**Post date:** [May 28, 2021, 7:18am UTC](https://forum.serverless.com/t/serverlesserror-invalid-tag-key-tag-keys-cannot-start-with-aws/15149/1 "2021-05-28T07:18:34Z")

</div>

Im deploying an api gateway for the first time and I get error with tags  
Serverless: [AWS apigateway 400 0.158s 0 retries] untagResource({  
798 resourceArn: ‘arn:aws:apigateway:us-east-1::/restapis/o9l5frekee/stages/stg’,  
799 tagKeys: [  
800 ‘STAGE’,  
801 ‘aws:cloudformation:logical-id’,  
802 ‘aws:cloudformation:stack-id’,  
803 ‘aws:cloudformation:stack-name’,  
804 [length]: 4  
805 ]  
806 })

Do not know the cause of the error, please your help.

---

<div class="post-metadata">

**Author:** ![ImHicham](https://yyz2.discourse-cdn.com/flex036/user_avatar/forum.serverless.com/imhicham/32/5935_2.png) [@ImHicham](https://forum.serverless.com/u/ImHicham)\
**Post date:** [July 1, 2021, 10:26am UTC](https://forum.serverless.com/t/serverlesserror-invalid-tag-key-tag-keys-cannot-start-with-aws/15149/2 "2021-07-01T10:26:35Z")

</div>

Hi @edwar95, I’ve come across the same error when deploying. Log looks exactly like yours. Did you solve this issue? thx in advance
