Serverless command line: status line keeps scrolling

I am new to serverless.

I run the command line (CLI) from my Ubuntu 20.04 desktop (using standard Konsole terminal). When I run commands, like “serverless deploy”, the status line keeps scrolling. It fills my terminal with hundreds of lines like:

⠙ Updating CloudFormation stack (9/10) (113s)

⠇ Retrieving CloudFormation stack (120s)

⠏ Updating (121s)

This is obviously a problem with my control/escape characters settings/processing. However, I could find no documentation on:

  • how to troubleshoot it
  • which settings to set/change to fix it
  • how to possibly suppress the status line updates
  • if other people had similar problem (and how they fixed it)

For the record, all my TERM apps/prompts work fine (for example, docker). Even running “serverless” command in an empty directory presents all prompts, including text menu navigation correctly.

My TERM variables/settings:
COLORTERM=truecolor
TERM=xterm-256color

I appreciate any advice/links.

dudlo

1 Like

Yup, we’re having similar issues with our CI logs being filled up with

⠏ Updating CloudFormation stack (2/12) (109s)

I can’t find any settings to disable this.

As a quick work around, using cat is a way to suppress the loading animation, progress indicator, event emitter or whatever you want to call it.

i.e.

$ serverless deploy | cat
1 Like

Same here, did nobody open a bug already ?

I actually do not think this is a bug/defect. The code works, it is just annoying that the progress dumps hundreds of lines into output. It is something serverless support could/should help fix and make the usage more enjoyable.

I realized I may not have explained/documented the symptoms fully. Here is sample output (showing 8 lines of several hundreds):


⠙ Creating CloudFormation stack (15s)

⠹ Creating CloudFormation stack (15s)

⠹ Creating CloudFormation stack (15s)

⠸ Creating CloudFormation stack (15s)

⠼ Creating CloudFormation stack (15s)

⠴ Creating CloudFormation stack (15s)

⠴ Creating CloudFormation stack (15s)

One workaround is listed above (filtering via cat). I found another one by running a different terminal client (in my case, GitHub - gnome-terminator/terminator: multiple GNOME terminals in one window). The output looks good with no further modifications/settings.

I also noted that this is only a problem with serverless version 3.x. I had to downgrade to version 2.72.3 (for other reasons) and the progress is shown correctly by simple dots in all terminals. It looks like version 3.x (I tested 3.8.0) is showing the progress in a way that clutters the stdout on some terminals.

I wish support would chime in about the TERM settings.

Ack, in sls v1 it was also fine.

The latest release has fixed this