# Problem with version 1.33: serverless deploy fails with strange error

**URL:** <https://forum.serverless.com/t/problem-with-version-1-33-serverless-deploy-fails-with-strange-error/6460>\
**Category:** Serverless Framework\
**Created:** [November 15, 2018, 4:51pm UTC](https://forum.serverless.com/t/problem-with-version-1-33-serverless-deploy-fails-with-strange-error/6460 "2018-11-15T16:51:25Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![pda](https://avatars.discourse-cdn.com/v4/letter/p/eb9ed0/32.png) [@pda](https://forum.serverless.com/u/pda)\
**Post date:** [November 15, 2018, 4:51pm UTC](https://forum.serverless.com/t/problem-with-version-1-33-serverless-deploy-fails-with-strange-error/6460/1 "2018-11-15T16:51:25Z")

</div>

Using AWS codepipeline + codebuild to invoke serverless. We usually install the latest using “npm install -g serverless”. Today the build failed with this error:

Running command serverless deploy --verbose --stage $STAGE --region us-east-1 --unitTest true

Serverless command “deploy devUnitTest” not found. Did you mean “deploy”? Run “serverless help” for a list of all available commands.

Reverting to 1.32 appears to work. Wondering if this is related to our use of plugins or ?? any clues appreciated.

---

<div class="post-metadata">

**Author:** ![Disentinel](https://avatars.discourse-cdn.com/v4/letter/d/e274bd/32.png) [@Disentinel](https://forum.serverless.com/u/Disentinel)\
**Post date:** [November 15, 2018, 5:36pm UTC](https://forum.serverless.com/t/problem-with-version-1-33-serverless-deploy-fails-with-strange-error/6460/2 "2018-11-15T17:36:06Z")

</div>

I have this problem too on my Gitlab CI pipelines.

right after npm i -g serverless  
command `serverless deploy --stage=staging ----aws-s3-accelerate  
transforms to “deploy LS1hd3MtczMtYWNjZWxlcmF0ZQ==”

–stage=staging disappears and —aws-s3-accelerate transforms to base64!

some kind of evil magic…

---

<div class="post-metadata">

**Author:** ![erikhyrkas](https://avatars.discourse-cdn.com/v4/letter/e/e19adc/32.png) [@erikhyrkas](https://forum.serverless.com/u/erikhyrkas)\
**Post date:** [November 15, 2018, 6:38pm UTC](https://forum.serverless.com/t/problem-with-version-1-33-serverless-deploy-fails-with-strange-error/6460/3 "2018-11-15T18:38:40Z")

</div>

I’m seeing the same issue.

Without digging too far, I can see that it isn’t handling the --stage correctly. I’ve reverted to 1.32 and things work fine.

---

<div class="post-metadata">

**Author:** ![erikhyrkas](https://avatars.discourse-cdn.com/v4/letter/e/e19adc/32.png) [@erikhyrkas](https://forum.serverless.com/u/erikhyrkas)\
**Post date:** [November 15, 2018, 7:18pm UTC](https://forum.serverless.com/t/problem-with-version-1-33-serverless-deploy-fails-with-strange-error/6460/4 "2018-11-15T19:18:56Z")

</div>

I created an issue: [https://github.com/serverless/serverless/issues/5496](https://github.com/serverless/serverless/issues/5496)

---

<div class="post-metadata">

**Author:** ![pda](https://avatars.discourse-cdn.com/v4/letter/p/eb9ed0/32.png) [@pda](https://forum.serverless.com/u/pda)\
**Post date:** [November 15, 2018, 7:47pm UTC](https://forum.serverless.com/t/problem-with-version-1-33-serverless-deploy-fails-with-strange-error/6460/5 "2018-11-15T19:47:42Z")

</div>

Thanks. I also reverted to 1.32.0 so I could get past the build issue.
