# Local OpenWhisk cert error?

**URL:** <https://forum.serverless.com/t/local-openwhisk-cert-error/1381>\
**Category:** Serverless Framework\
**Tags:** openwhisk\
**Created:** [February 24, 2017, 12:01am UTC](https://forum.serverless.com/t/local-openwhisk-cert-error/1381 "2017-02-24T00:01:55Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![nerdguru](https://yyz2.discourse-cdn.com/flex036/user_avatar/forum.serverless.com/nerdguru/32/248_2.png) [@nerdguru](https://forum.serverless.com/u/nerdguru)\
**Post date:** [February 24, 2017, 12:01am UTC](https://forum.serverless.com/t/local-openwhisk-cert-error/1381/1 "2017-02-24T00:01:55Z")

</div>

Trying out the examples for the plug in and they work great against Bluemix, but I’m getting a certificate error when running against a local OpenWhisk install:

```
Failed to deploy function (my_service2-dev-hello) due
to error: Error encountered calling OpenWhisk: Error:
self signed certificate

```

and I can duplicate it with the wsk CLI just trying a hello:

```
error: Unable to invoke action 'utils/echo': Post https://192.168.33.13/api/v1/namespaces/whisk.system/actions/utils/echo?blocking=true&result=true: x509: cannot validate certificate for 192.168.33.13 because it doesn't contain any IP SANs

```

I’m not finding anything on certs on the OpenWhisk project page anywhere, so I thought I’d try here. Has anybody else run into this?

---

<div class="post-metadata">

**Author:** ![nerdguru](https://yyz2.discourse-cdn.com/flex036/user_avatar/forum.serverless.com/nerdguru/32/248_2.png) [@nerdguru](https://forum.serverless.com/u/nerdguru)\
**Post date:** [February 24, 2017, 2:15am UTC](https://forum.serverless.com/t/local-openwhisk-cert-error/1381/2 "2017-02-24T02:15:06Z")

</div>

UPDATE

I get the same self signed cert error when I vagrant ssh into my OpenWhisk box and install the serverless framework there, even after setting the environment variables as instructed. Unlike when I tried it before, the wsk command line works just fine here, though.

 ![](https://canada1.discourse-cdn.com/flex036/uploads/serverless/original/1X/24091b0c199dd425f64e85254ad73a002f172c99.png)

Anybody else run into this?

---

<div class="post-metadata">

**Author:** ![avwsolutions](https://yyz2.discourse-cdn.com/flex036/user_avatar/forum.serverless.com/avwsolutions/32/482_2.png) [@avwsolutions](https://forum.serverless.com/u/avwsolutions)\
**Post date:** [February 24, 2017, 9:59pm UTC](https://forum.serverless.com/t/local-openwhisk-cert-error/1381/3 "2017-02-24T21:59:58Z")

</div>

Hi I have got this error too. With the wsk the -i option solves it, but in this case not. I have seen a possibility (rest api) to send over this ignore option in the contractor for the deploy.

Did you solved the problem?

---

<div class="post-metadata">

**Author:** ![nerdguru](https://yyz2.discourse-cdn.com/flex036/user_avatar/forum.serverless.com/nerdguru/32/248_2.png) [@nerdguru](https://forum.serverless.com/u/nerdguru)\
**Post date:** [February 24, 2017, 11:19pm UTC](https://forum.serverless.com/t/local-openwhisk-cert-error/1381/4 "2017-02-24T23:19:49Z")

</div>

Nope, still seeing it. Misery loves company though 8)

---

<div class="post-metadata">

**Author:** ![avwsolutions](https://yyz2.discourse-cdn.com/flex036/user_avatar/forum.serverless.com/avwsolutions/32/482_2.png) [@avwsolutions](https://forum.serverless.com/u/avwsolutions)\
**Post date:** [February 25, 2017, 12:50pm UTC](https://forum.serverless.com/t/local-openwhisk-cert-error/1381/5 "2017-02-25T12:50:43Z")

</div>

> [@nerdguru](#):
>
> Nope, still seeing it. Misery loves company though 8)

The issue is accepted and will be part of the the release / update. See below the Github issue record with comment history.

> <https://github.com/serverless/serverless-openwhisk/issues/36>
>
> Add ignore\_certs constructor option (or make it available) like wsk -i). Current…ly I get an error during deploy of the boilerplate.
> 
> Failed to deploy function (localess-dev-hello\_world)
> due to error: Error encountered calling OpenWhisk: Error:
> self signed certificate

---

<div class="post-metadata">

**Author:** ![jthomas](https://yyz2.discourse-cdn.com/flex036/user_avatar/forum.serverless.com/jthomas/32/47_2.png) [@jthomas](https://forum.serverless.com/u/jthomas)\
**Post date:** [March 11, 2017, 1:22pm UTC](https://forum.serverless.com/t/local-openwhisk-cert-error/1381/6 "2017-03-11T13:22:52Z")

</div>

This has now been resolved with the 0.5 release of the plugin, please upgrade and try again.

Use the following configuration to support this.

````auto
provider:
    name: openwhisk
    ignore_certs: true
```
````

---

<div class="post-metadata">

**Author:** ![nerdguru](https://yyz2.discourse-cdn.com/flex036/user_avatar/forum.serverless.com/nerdguru/32/248_2.png) [@nerdguru](https://forum.serverless.com/u/nerdguru)\
**Post date:** [March 20, 2017, 4:58pm UTC](https://forum.serverless.com/t/local-openwhisk-cert-error/1381/7 "2017-03-20T16:58:04Z")

</div>

I finally got a chance to validate this and it’s working great now, thanks so much.

I hope we get a chance to meet in Vegas, I get there Tuesday morning and hope to escape the show floor for a few OpenWhisk sessions.
