# Cannot deploy same service to different stages

**URL:** <https://forum.serverless.com/t/cannot-deploy-same-service-to-different-stages/13354>\
**Category:** Serverless Framework\
**Tags:** aws, release\
**Created:** [December 9, 2020, 10:00am UTC](https://forum.serverless.com/t/cannot-deploy-same-service-to-different-stages/13354 "2020-12-09T10:00:23Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![yo1la](https://avatars.discourse-cdn.com/v4/letter/y/8797f3/32.png) [@yo1la](https://forum.serverless.com/u/yo1la)\
**Post date:** [December 9, 2020, 10:00am UTC](https://forum.serverless.com/t/cannot-deploy-same-service-to-different-stages/13354/1 "2020-12-09T10:00:24Z")

</div>

Hi

I have a bunch of services. all of these services are already deployed to dev stage, some were even deployed to stg as well.

I want to promote the current state of my services to dev, stg and prod. however, if I run `sls deploy -s dev` for service X and then run `sls deploy -s stg` or `sls deploy -s prod` I get a “stack with id XX does not exist” error.

I am sure I am missing something very basic - but have no idea what it is…

Thanks for your help.

---

<div class="post-metadata">

**Author:** ![garethmcc](https://yyz2.discourse-cdn.com/flex036/user_avatar/forum.serverless.com/garethmcc/32/2276_2.png) [@garethmcc](https://forum.serverless.com/u/garethmcc)\
**Post date:** [December 10, 2020, 10:44am UTC](https://forum.serverless.com/t/cannot-deploy-same-service-to-different-stages/13354/2 "2020-12-10T10:44:02Z")

</div>

This error usually occurs when I do not have enough S3 buckets capacity available. AWS by default only allows you 100 S3 buckets per AWS account. I am sure if you opened the AWS console for the account you are deploying to you would find there are a lot of S3 buckets you could delete.
